运维百科

Windows server PHP环境_php简介

一、    简介

1、 PHP版本如何选择?应该使用哪个版本?

如何选择PHP5.3的VC9版本和VC6版本

    VC6是什么?

    VC6就是legacy Visual Studio 6 compiler,就是使用这个编译器编译的。

    VC9是什么?
    VC9就是the Visual Studio 2008 compiler,就是用微软的VS编辑器编译的。

    VC11是什么?

    VC11就是the Visual Studio 2012 compiler,就是用微软的VS编辑器编译的。

    VC14是什么?

    VC14就是the Visual Studio 2015 compiler,就是用微软的VS编辑器编译的。

那我们如何选择下载哪个版本的PHP呢?
    如果你是在windows下使用Apache+PHP的,请选择VC6版本(从5.3.5左右后的版本就已经没有VC6了,因为VC6的架构已经不满足需求了,所以全部换成了VC9,现在的VC9也是支持apache的。但都建议Apache下用FastCGI模式);
    如果你是在windows下使用IIS+PHP的,请选择VC9版本。

   注:php5.2没有vc9,php5.3、php5.4没有vc6。

    如果你下载的是VC9版本的,就需要先安装Visual C++ Redistributable for Visual Studio 2008 SP1 x86 or x64

如果你下载的是VC11版本的,就需要先安装Visual C++ Redistributable for Visual Studio 2012 x86 or x64

如果你下载的是VC14版本的,就需要先安装Visual C++ Redistributable for Visual Studio 2012 x86 or x64

附PHP官方原文:

   

2、 PHP运行方式(共三种)。

a)   CGI方式加载PHP环境,通常就是IIS里面配置解释器为php.exe,早期比较常见,目前使用较少。

b)   ISAPI方式加载PHP环境,通常就是IIS里面配置解释器为php5isapi.dll,执行方式是以DLL动态库的形式使用,可以在被用户请求后执行,在处理完一个用户请求后不会马上消失,所以需要进行线程安全检查,这样来提高程序的执行效率,所以如果是以ISAPI来执行PHP,建议选择Thread Safe版本。

c)   FastCGI方式加载PHP环境,IIS7.0开始内置FastCGI了,以单一线程来执行操作,所以不需要进行线程的安全检查,除去线程安全检查的防护反而可以提高执行效率,PHP的Thread Safe和Non Thread Safe版本,先从字面意思上理解,Thread Safe是线程安全,执行时会进行线程(Thread)安全检查,以防止有新要求就启动新线程的CGI执行方式而耗尽系统资源。Non Thread Safe是非线程安全,在执行时不进行线程(Thread)安全检查。所以,如果是以FastCGI来执行PHP,建议选择Non Thread Safe版本。

注:微软的说法是 fastcgi使用非线程安全版PHP执行效率会更高,也推荐的是非线程安全版,但是很多商业程序是用zend加密了的,因此按照你的实际情况来下载php包。

 


本站部分资源收集于网络,纯个人收藏,无商业用途,如有侵权请及时告知!

3
分享到:

评论 0

取消
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址